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Web Pages for the Beginner 
·  Any file that you save in the public_html folder on your network 

account is immediately and automatically on the web and available 
world-wide. 

·  You can save any kind of file in the public_html folder, but some 
are special… 

o any file that ends with .htm or .html is assumed to be a file 
containing HTML code, which describes how a web page 
should look. 

o Bonus trivia: HTML means HyperText Markup Language. 

o a file named index.html is the page that our web server 
looks for first. 

o More Bonus trivia: a web server is the computer that 
answers requests for web pages.  When you type 
www.cnn.com into a web browser, a web server at CNN 
sends a page back to you. 

·  HTML pages contain links to other files in your folder, in other 
folders on SSTX.org, and on any other web server in the world. 

·  HTML is a messy language, and is difficult to get right on your 
own.  Web page editors let you type what you want, and create the 
HTML code for you. 

·  We have two different web editor programs: MacroMedia 
DreamWeaver and Microsoft FrontPage.  You can install either or 
both on a computer – at home and/or at school.  You can use any 
web editor program to edit the files – regardless of what editor was 
used to create them. 

·  This document uses DreamWeaver in its examples.  The process 
is the same if you use FrontPage, but the names and locations of 
buttons and commands will be different. 
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�  how to create web pages on your school file server 

·  Open DreamWeaver.  If you are asked if you want to “define a 
site”, click on “No” or “Cancel”. 

·  Create a new empty web document.  From the File menu, select 
New.  Choose “Basic Page” in the left panel and “HTML” in the 
center panel.  Click on the “Create” button. 

 

 

 

 

 

 

 

 

 

 

 

o If you already have a web site started, ask for help 
before saving this file.   

o Type your name at the top of the page.  Save the document 
as public_html/index.html.  (Click on the File menu, and 
choose Save.)  Minimize DreamWeaver. 

o This is your “Home Page”. 

·  Open a web browser (Internet Explorer or Firefox), and type into 
the Address bar:  

spartans.sstx.org/~<your log-in name> 

and press <enter>. 

 

 

 

 

 

 

for example, my web page is: spartans.sstx.org/~bgray 

·  Your web page should appear in the browser. 
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·  Bonus trivia: the ~ character is called the tilde (TIL-duh). 

·  Maximize DreamWeaver.  Change the text on the web page a bit: 
Make your name a little bit bigger and center it on the page. 

o Select the line of text containing your name 

o At the bottom of the DreamWeaver window, click on the. 
Combo box arrow to the right of the “Format” field.  Choose 
“Heading 1”.This will make the selected text appear in a 
style called “Heading 1”.  Each format represents a different 
combination of size, font, and attributes (bold, italic, etc). 

 
 

o At the bottom of the DreamWeaver window, click on the 
“Align Center” button.  It looks just like the “Center Text” 
button in Word. 

 

 
 

o Save the document again.  (Click on the File menu and 
choose Save.) 

o Minimize DreamWeaver and look at the page in your web 
browser…it looks just like it did before you made these last 
changes. You have to tell the browser to get the page from 
the web server again.  Click on the “Refresh” button in the 
tool bar. 
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·  Switch back to DreamWeaver.  In one of the tool bars at the top of 
the window, look for the “Title” field.  Type a title for your page in 
the field, save it, and look at it in your web browser.  Don’t forget to 
refresh the page.  The title you just typed appears in the title bar at 
the top of the web browser window.  Your page title should include 
your name and other information about the page.   

 

 
 

(For example, when you create a page for a class in a few 
seconds, include your name and the class name in the title. 

 

·  Create a new empty web document.  From the File menu, select 
New.  Choose “Basic Page” in the left panel and “HTML” in the 
center panel.  Click on the “Create” button. 

 

 

 

 

 

 

 

 

 

 

 

 

o Type the name of one of your classes (the same class that 
you typed on the previous page).  On the next line, type a 
one-sentence description of the course. 
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o Format the Class name in style “Heading 1” and the 
description in style “Heading 3”. 

o Add a title to the page. 

o Save the file with an appropriate name, using letters and 
numbers only – no spaces or other characters.  The file 
name should end with .html 

·  Create a link from the index page to the page for the class. 

o Select the window containing index.html.  Select the text 
that is the name of the class for which you just created a 
page. 

 

 

 

 

 

 

o At the bottom of the DreamWeaver window, click on the file 
folder to the right of the “Link” field.  Select the HTML file for 
the class and click OK. 

 
o The text will change appearance: It will turn blue and will be 

underlined. 

o Save the document again, and look at it in the web browser.  
(Don’t forget to refresh.) 

o Click on the link to your class.   

·  Maximize DreamWeaver again.  In the page for the class, add a 
link that points back to your home page.  Follow the instructions in 
the previous step, except select the file “index.html” as the link 
target. 

·  Save the documents in DreamWeaver, and look at them in the web 
browser.  Each page should include a link to the other. 

·  In general, almost every web page should include a link back to its 
home page. 

 

�  End of: how to create web pages on your school file server 
account 



Page 6 

�  how to add other formatting features to text 
 

 

 
 

·  Bulleted lists have a small dot to the left of each paragraph (like 
this one does) 

·  Numbered lists have a sequential number to the left of each 
paragraph. 

·  Paragraphs can be indented more or less by using the 
increase/decrease indent buttons. 

 

To add any of these formats, type the text, then select it, and then 
click on the button.  To remove the bullets or numbers, select the 
text and click on the button again.  

 

·  To add a horizontal line between paragraphs (to separate sections 
of a page), use a “Horizontal Rule”.  From the Insert menu, select 
the HTML sub-menu and select “Horizontal Rule”.  Experiment with 
the height, width, alignment, and shadow features. 

 
 

End of: how to add other formatting features to text 
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�  how to add pictures to a web page 
 

You can easily add a picture to your web page – but the picture 
must first be stored in your public_html folder.   

 

We will first save a picture into your folder, and then make it 
appear on one of your web pages.  Finally, we will turn the picture 
into a link, so that clicking on the picture will take the user to 
another web page. 

 

Save an image into your public_html folder: 

·  In the web browser, go to my home page:  

spartans.sstx.org/~bgray 

·  Point to the school shield in the upper left corner of the screen.  
Right click. 

 

 

 

 

 

 

 

 

 

 

 

·  From the context menu, select “Save Picture As…” 

·  Navigate to your public_html folder and save the image. 

 

Add the picture to your web page 

·  Switch to DreamWeaver.  Select your home page (index.html). 

·  Point and click to place your cursor on the page where you 
want the image to appear. 
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·  Click on the button that has a picture of a tree.  This is the 
“Image” button. 

·  Navigate to your public_html folder, and select the file 
containing the school shield.  Click on OK. 

·  The image is now part of your web page. 

·  Save the file.   Switch to the web browser, refresh the page, 
and verify that the image appears. 

·  You can change the location of the image by changing the 
alignment (left, right, or centered), just as you would for text. 

 

Make the picture a click-able link 

·  Switch to DreamWeaver.  Select the page with the image. 

·  Single-click to select the image. 

·  At the bottom of the DreamWeaver window, click in the Link 
field. 

·  You can type the link information instead of using copy/paste.  
In the link field type http://www.sstx.org and press enter.  Unlike 
text that is a link, the picture will not look any different. 

·  Bonus trivia: http means HyperText Transport Protocol.  The 
entire address is called a URL – a Uniform Resource Locator. 

·  Save the file.   Switch to the web browser and refresh the page. 

·  In the web browser, point your mouse at the image.  The 
mouse pointer will change to indicate that the image is a link.  
Click on the link. 

 

 End of: how to add pictures to a web page 
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�  how to create lists of homework assignments… 
…so you never have to write them on the board again 

·  If you already have a list of assignments in a Word document 
(or in almost any other electronic form) you can copy and paste 
the assignments into your HTML page. 

·  One way to create your assignment list from scratch is to use a 
table.  A table is made up of rows and columns.  The rows and 
columns are made up of cells.  You add text and images to the 
cells. 

o In DreamWeaver, select the document for your class. 

o Click on the “Insert Table” button. 

o Type the number of rows and columns you want.  You 
can add or remove rows and columns later.  You 
probably want at least two columns – maybe three – one 
for the due date, one for the assignment, and maybe one 
for links to resources. 

o Make the width 100 percent. 

o Click OK. 

o To re-size the columns in the table, point the mouse 
directly at one of the column dividers, then click and drag 
the divider left or right. 

o Type a column header into each column of the first row.  

o Type assignment information into the columns in the 
second row.  Use the TAB key or the mouse to move 
from one cell to the next. 

o To add a new row at the bottom of the table, place the 
cursor in the lower right cell and press the TAB key. 
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After the table is built, you can add or remove rows and columns. 

 

 
 

o To add a new row above an existing row, place the 
cursor in any cell in the existing row.  From the Modify 
menu, select the Table sub-menu, and choose “Insert 
Row”. 

o To add a new column to the left of an existing column, 
place the cursor in any cell in the existing column.  From 
the Modify menu, select the Table sub-menu, and 
choose “Insert Column”. 

o To add a row below or a column to the right, place the 
cursor in a cell.  From the Modify menu, select the Table 
sub-menu, and choose “Insert Rows or Columns”. 

o To combine two or more cells in a row into a single cell, 
you must “merge” the cells.  Select the cells to be 
merged, then from the Modify menu, select the Tables 
sub-menu and select “Merge Cells”. 

 

�  End of: how to create lists of homework assignments 
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�  how to use your assignment web page effectively 

·  If possible, you should put the assignments for several days 
on the page at one time. 

·  Some students will look at the web page each day for that 
day’s assignment.  Others will print the page as soon as you 
post it. 

·  If you make changes to an assignment after it is posted, 
announce in class that you have done so.  (You don’t need 
to list the changes – just say “I’ve made some changes on 
the assignment web page.”) 

·  If a student asks you what the assignment is, always refer 
him to the web page.  Students must develop the habit of 
checking the web page. 

·  Write the entire web address on the board every day for the 
first few days that you use the assignment page.  Refer to it 
at the start and end of each class for a few days to remind 
students to look there. 

·  Keep a printed copy of the assignment page with you if you 
teach in a room without a computer. 
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�  how to create a page that will help your students  
get started on their next essay or paper 

 

A link to a web page that you did not create is almost as easy as 
linking to one of your own.  You must provide a little more 
information about the page you want to link to. 

 

·  In the web browser, go to the CNN web page (www.cnn.com) 
and click on any story link (so that you are not looking at the 
CNN front page. 

·  Select all of the text in the address bar.  (Be sure to select the 
first part of the address: http://.) 

 

 

 

 

 

 

 

 

·  Copy the address that you just selected.  Point at the Address 
bar, right-click, and choose Copy. 

·  Switch to DreamWeaver, and select your home page 
(index.html). 

·  Type “A story on CNN” 

·  Select the text you just typed. 

·  At the bottom of the DreamWeaver window, click in the “Link” 
field.  Right-click, and choose Paste.  The text that was in the 
Address Bar of the web browser should now appear in the Link 
field.  Press Enter.  The text you typed on your home page is 
now a link.  (It has turned to blue text and is underlined.) 

·  Save the page in DreamWeaver. 

·  Switch back to the web browser, and go back to your home 
page.  You must click the refresh button to see the new version 
of your home page. 

·  Click on the link to the CNN story.  The CNN story should be 
displayed. 
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You can repeat this process as many times as needed to add links 
to web pages that you want your students to see.  You may want 
to create a new web page containing links for a specific 
assignment, and add a link to it from your home page or a class 
assignment page. 

 

 

�  End of: how to create a page that will help your students get 
started on their next essay or paper 
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�  how to change the background color on a web page 
 

·  From the Modify menu, choose Page Properties 

 

·  Click on the word “Appearance” in the left column. 

·  Click on the small square next to the word “Background”.  A color 
selection dialog will open.  Point and click on a color.  (Usually, a 
light color works best for backgrounds, so that there will be 
contrast with the black text. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

·  Click on “Apply” to se the color on your page.  Repeat as needed 
until you find a color you like.  Then click OK. 

·  Save the page in DreamWeaver and look at it again in the web 
browser. 

 

�  End of: how to change the background color on a web page 


